[egenix-users] Django 1.8 compatibility

Charlie Clark charlie at egenix.com
Mon Apr 6 19:10:27 CEST 2015

Am .04.2015, 18:04 Uhr, schrieb Wilhelm, Joey <Joey.Wilhelm at gannett.com>:

> Hello,

> Since Django 1.8 was released this past Wednesday, April 1 as the next  
> LTS version, 1.4 is going to lose support in 6 months. Also, Django 1.5  
> has already lost support. With this in mind, are there plans to provide  
> compatibility with Django 1.8 in the mxODBC Django Database Engine? If  
> so, what kind of timeline could be expected on this change? There were a  
> number of backwards incompatible changes made to the database backend  
> API  
> (https://docs.djangoproject.com/en/1.8/releases/1.8/#database-backend-api),  
> meaning that all database backends will need to be updated in order to  
> work with Django 1.8.

Hi Joey,

thanks for the note. We'll certainly be investigating this to see what  
kind of work is needed to support 1.8. Are you aware of any specific  

FWIW I will personally be at PyCon in Montreal this week if there are  
things that need discussing, though I must admit that mxODBC is not my  
personal area of expertise!

Charlie Clark

Professional Python Services directly from the Source
>>> Python/Zope Consulting and Support ...        http://www.egenix.com/
>>> mxODBC.Zope.Database.Adapter ...             http://zope.egenix.com/
>>> mxODBC, mxDateTime, mxTextTools ...        http://python.egenix.com/

::: Try our new mxODBC.Connect Python Database Interface for free ! ::::

    eGenix.com Software, Skills and Services GmbH  Pastor-Loeh-Str.48
     D-40764 Langenfeld, Germany. CEO Dipl.-Math. Marc-Andre Lemburg
            Registered at Amtsgericht Duesseldorf: HRB 46611

More information about the egenix-users mailing list