[egenix-users] Using mxODBC Zope DA 2.0 with Plone 4.1 (was: No module named threadlock?)

Cliff Quinn cliffq at islandwood.org
Mon Sep 5 16:24:25 CEST 2011

Hi Marc-Andre,

I've tried a number of different versions of the string to the location
of the license file, and can't get anything to work - I'm still getting
the error: 

ImportError: eGenix mxODBC Zope DA could not find license module

I tried these strings (I'm only starting one client), and the buildout
succeeds in all cases (it fails if I get the input directory wrong):

input =
input =
input =

I'm beginning to think that the license file that's there is not
correct. First of all, it's not named "mxodbc_zopeda_license.py" but
"license.py". I've tried making a copy of the file(s) with the new name
and that doesn't help.

The license is from 2008, and says it's for version 2.1. Do I need a new
license? Do I have to change something in the contents of the license? I
understood it would be good for all versions. 



> ### Install the Zope instance licenses for egenix-mxodbc-zopeda
> [egenix-mxodbc-zopeda-license-client1]
> recipe = collective.recipe.template
> input = /path-to-license-dir-for-client-1/mxodbc_zopeda_license.py
> output = ${client1:location}/lib/python/mxodbc_zopeda_license.py

More information about the egenix-users mailing list