[egenix-users] No module named threadlock?

Cliff Quinn cliffq at islandwood.org
Wed Aug 31 00:04:34 CEST 2011

> Please clear out the egg file from the cache and retry.
> Hope that helps,

 [Cliff Quinn] 
So I cleared out everything from the Plone/buildout-cache/download/dist
and the egenix folder from Plone/buildout-cache/eggs, and things seem
better on the UCS front.

Last problem I hope:

  File "Products/mxODBCZopeDA/__init__.py", line 33, in <module>
    def get_starter():
  File "Products/mxODBCZopeDA/ZopeDA.py", line 351, in <module>
ImportError: eGenix mxODBC Zope DA could not find license module

In the zeo version of buildout there is no ${instance:location} value as
recommended in your documentation for the 

"output = ${instance:location}/lib/python/mxodbc_zopeda_license.py"

line in the [egenix-mxodbc-zopeda-license] section. I tried using the
${buildout:directory} value instead, and this doesn't seem to work. I
tried hard-coding the absolute path, and that didn't work. I noted that
the products/lib/python directories were owned by root:root, and I
chmoded them to plone:root, and that didn't work. Where exactly is the
program looking?


More information about the egenix-users mailing list