[egenix-users] Still can't install mxODBCZopeDA on plone 3.1.1 buildout

M.-A. Lemburg mal at egenix.com
Thu May 22 13:13:19 CEST 2008

On 2008-05-22 06:35, Cliff Quinn wrote:
> I've been trying for two weeks and have put a lot of time into trying to
> get mxodbc running on the above buildout on a Ubuntu 6.06 server on an
> i686 machine. I'm really frustrated, but must be very close.

Have you tried installing the mxODBC Zope DA as per the standard
instructions in the manual using the simple unzip product installation
procedure ? Or is there a reason you have to use buildout for this ?

 > ...
> This seems to all compile ok when I run bin/buildout, but when I run the
> site I get the following error message:
> ...
>   File "Products/mxODBCZopeDA/ZopeDA.py", line 246, in find_subpackages
> ImportError: no usable mxODBC subpackage found: iODBC: libiodbc.so.2:
> cannot open shared object file: No such file or directory; unixODBC:
> initialization of module mxODBC failed
> (mx.ODBC.unixODBC.LicenseError:mx.ODBC.license is not a license for
> product version 3.0.1)

The above basically says that:

  * you don't have iODBC installed (which is fine - you only need one
    ODBC manager installed)

  * you do have unixODBC installed, but the mxODBC Zope DA picks up
    the wrong mx/ package directory

Note that mxODBC Zope DA ships with mxODBC 2.1. You get the above
license message in case you have installed the stand-alone egenix-mxodbc
distribution as well - which you shouldn't, since the Zope DA already
comes with everything you need to run the DA (ie. egenix-mx-base and

> There is a license.py and.txt in the parts/mxodbc/mx/ODBC apparently
> placed there by the buildout
> Can you please help me figure this out - I've spent waay too much time
> on this.

I'm really sorry that you're having so much trouble in getting
zc.buildout to work.

I've had another look at Martijn's buildbot recipe:


It turns out that the recipe addresses a different use case:

The recipe installs the *stand-alone* mxODBC version (and corresponding
license). This can be used in Zope and Plone just fine, but doesn't
include the mxODBC Zope DA that you are trying to install.

The Zope DA product is packaged in egenix-mxodbc-zopeda and comes
with everything you need to run the Zope DA.

Please do try the standard installation procedure first. It is
really easy to get a Zope 2 product installed using that approach.

If you do need to use buildout, you should be able to add the mxODBC
Zope DA product using the approach described here for Zope 2 products:


There's only one catch to this: because our products still support
Zope versions prior to Zope 2.7 (which changed the layout of
Zope products), there is a directory move step in the installation
which buildout will probably have trouble with.

You may need to recreate an archive from the ones you download
from our site, that includes the moved product directory to make
it work with plone.recipe.distros recipe.

It should also be possible to write Plone recipe specifically for
the mxODBC Zope DA, using Martijn's recipe as basis.

For the next release of the Zope DA, we'll change the layout to make
it a drop-in installation again and also look into providing eggs.
Hopefully, that makes using it with buildout easier.

I'm sorry, but we cannot change the layout of the Zope DA 1.0
release since we have existing customers who rely on it.

Marc-Andre Lemburg

Professional Python Services directly from the Source  (#1, May 22 2008)
 >>> Python/Zope Consulting and Support ...        http://www.egenix.com/
 >>> mxODBC.Zope.Database.Adapter ...             http://zope.egenix.com/
 >>> mxODBC, mxDateTime, mxTextTools ...        http://python.egenix.com/

:::: Try mxODBC.Zope.DA for Windows,Linux,Solaris,MacOSX for free ! ::::

    eGenix.com Software, Skills and Services GmbH  Pastor-Loeh-Str.48
     D-40764 Langenfeld, Germany. CEO Dipl.-Math. Marc-Andre Lemburg
            Registered at Amtsgericht Duesseldorf: HRB 46611

More information about the egenix-users mailing list