[egenix-users] Still can't install mxODBCZopeDA on plone 3.1.1 buildout

Martijn Pieters mj at zopatista.com
Thu May 22 12:17:20 CEST 2008

On Thu, May 22, 2008 at 6:35 AM, Cliff Quinn <cliffq at islandwood.org> wrote:
> I've downloaded the mxODBCZopeDA package from your site, and put it in the
> buildout/products directory.

Alternatively you could use the plone.recipe.distros for this (usually
the section is already there, look for [productdistros], add the
download url to the urls option). This has nothing to do with your
problem, however.

> This seems to all compile ok when I run bin/buildout, but when I run the
> site I get the following error message:
>   File "Products/mxODBCZopeDA/ZopeDA.py", line 246, in find_subpackages
> ImportError: no usable mxODBC subpackage found: iODBC: libiodbc.so.2: cannot
> open shared object file: No such file or directory; unixODBC: initialization
> of module mxODBC failed (mx.ODBC.unixODBC.LicenseError:mx.ODBC.license is
> not a license for product version 3.0.1)
> There is a license.py and.txt in the parts/mxodbc/mx/ODBC apparently placed
> there by the buildout

Indeed, the recipe places them there from the zip file, but it doesn't
do any sanity checking on them. The license header should read
something like:

    PRODUCT:  mxODBC - Python ODBC Interface
    VERSION:  3.0
    LICENSE:  1 CPU License
              for one (1) CPU

That's from the docstring in license.py. Other than that, I have no
idea how to troubleshoot this.

Martijn Pieters

More information about the egenix-users mailing list